Понедельник, 20 февраля 2017 09:01

в php 5.6 нет mysql_connect()

Оцените материал
(0 голосов)

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in - выскачила данная ошибка из-за версии php ( версия 5.6 )

в php 5.6 нет  mysql_connect()

НУ и для того чтобы все работало корректно надо либо понизить версию php, либо установить вот это

Кому не лень просто регистрируется и качает данный драйвер.

залил данный файл на диск

Модуль MySQLiz добавлена поддержка mysqli для Опенкарт.
Удаляет “РНР сообщение: РНР устаревшие: функцию mysql_connect(): MySQL расширение является устаревшей и будет удалена в будущем: используйте в mysqli или pdo вместо этого в /var/www/opencart/system/database/mysql.php по строке 6...” сообщение об ошибке в вашем opencart, когда вы установили opencart со последних версий PHP.
Поддерживает EDGE-режущий версии PHP 5, включая PHP 5.5.+.

Установка

1. Извлечь все из архива. Вы увидите “каталог выгрузки”.
2. Скопируйте все из папки “залить” в свой каталог Опенкарт (через FTP или SFTP).
3. В config.php и admin/config.php заменить “define('DB_DRIVER', 'mysql');” на “define('DB_DRIVER', 'mysqliz');”

Прочитано 889 раз Последнее изменение Воскресенье, 06 августа 2017 21:30
Другие материалы в этой категории: OpenCart 2.0.1 – добавление русского языка »

Оставить комментарий

Убедитесь, что Вы ввели всю требуемую информацию, в поля, помеченные звёздочкой (*). HTML код не допустим.